Unexpected error has occured

May 4, 2012 at 4:33 PM
Edited May 4, 2012 at 4:35 PM

I am using SharePoint Foundation 2010 and I am having a problem with the newest version of SPUserPoll. When i want to add this webpart to my site this error occurs (my sharepoint environment is not in english so i will try to roughly translate the error):

"An unexpected error has occured.

Web part management page: if you have sufficient permissions, you can use this site to temporarily close web parts or revoke personal settings. For more information turn to site administrator."

After that i cannot access my site and the same error keeps appearing. To solve this problem i have to click on Web part management page link in the error and on Web part man. page i have to delete SPUserPoll web part from my site.

Does anyone know how to solve this problem?

May 24, 2012 at 8:34 AM

Hi,

Anyone know how to resolve this? I also have the same issue face.

 

May 24, 2012 at 2:57 PM

Hi,

I am stuck with same problem. Somehow it created only one list Available SPUserPolls and I can't figure out how to make all required lists to appear?

My error log:

System.ArgumentException: List 'SPUserPoll answers' does not exist at site with URL 'http://vm-share/sites/dev'. at Microsoft.SharePoint.SPListCollection.GetListByName(String strListName, Boolean bThrowException) at SPUserPoll.Data.Components.AnswersList.AnswerList() at SPUserPoll.Presentation.WebParts.UserControls.PollAdminMenu.AnswersListUrl() at SPUserPoll.Presentation.WebParts.UserControls.PollAdminMenu.Page_Load(Object sender, EventArgs e) at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.LoadRecursive() ... 61d34e46-3e4c-4273-ac72-6fa3b39e09fc
...at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Control.AddedControl(Control control, Int32 index) at SPUserPoll.Presentation.WebParts.PollDisplayWebPart.CreateChildControls() at System.Web.UI.Control.EnsureChildControls() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Control.PreRenderRecursiveInternal() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 61d34e46-3e4c-4273-ac72-6fa3b39e09fc

Dainius

Jul 10, 2012 at 6:05 AM

The same problem. SharePoint is not in English

Aug 10, 2012 at 7:14 PM

I had the same problem, I went and created the Custom Lists with names: SPUserPoll answers and SPUserPoll responses and then deleted them.  After that, I was able to add the SPUserPoll webpart. NOW, I'm unable to add answers.  I click on the "Manage answers" link but nothing happens.

Sep 8, 2012 at 5:44 PM

You need the lists SPUserPoll answers and SPUserPoll responses. I created those and everything works. I just cannot submit though, another exception which I will dig into.

Jun 16, 2014 at 5:47 PM
No luck. Still get the error after creating 2 custom lists by those names. Would very much appreciate documentation so we actually know how this is supposed to work.