Manage Answers click does nothing

Mar 6, 2013 at 6:37 PM
Hi everyone,

Here's what I've done so far:
  1. Downloaded the source and .wsp
  2. Deployed the .wsp
  3. Activated the feature
  4. Tried to add the WP to a page but got some errors that needed me to create the the SPUserPoll answers and SPUserPoll responses lists
  5. After creating the lists I was able to add the WP, set the title and question fields and save the WP (clicking OK in the WP editor)
  6. The WP appeard to save and is on the page with the "Manage answers" link
  7. I click on the link and nothing happens althoug
I'm in a SP2010 site and I am a SC Admin. I'm not really sure where to go from here. Has anyone else ever experienced this? Any other information you need to help narrow down the possible cause?

Thanks in advance for any help.

Mar 6, 2013 at 7:38 PM
I have an update that at least moves me a bit closer. I referenced the spuserpoll.js file in my Master page and now the dialog at least opens but it opens for about a second and then vanishes.
Mar 6, 2013 at 8:00 PM
Another update. While looking at the .js I saw that the URL is:


So I plugged that straight into the browser address bar and the page comes up. So I added 3 items to that list. Then I had to go back to the WP and check Publish and when I click on the Publish link while the page is checked out I get...

"One or more field types are not installed properly"

This does not mean my error of the dialog not opening is solved. I just thought I was at least going to get to manually add some answers and then be able to view the poll.
Mar 6, 2013 at 8:28 PM
To continue....

I opened SP Manager 2010 and went to the SPPollUsers answers list and in the Item node I selected the "Blue" entry that I had added manually.

The "IconOverlay" field has the following next to it:

"Invalid field name. {b77cdbcf-5dce-4937-85a7-9fc202705c91} /Lists/SPUserPoll answers"

Does that mean anything to anyone?
Mar 28, 2013 at 7:49 PM
Hmm, you would think codeplex would let me know that theirs discussions going on.

I just opened up the 2010 SPUserPoll project for the first time since the initial beta build. I'll be updating the 2010 version to be a bit more resilient during deployment (pretty flaky at the moment). And adding 2013 support as well.

@MikeGargone: that looks like an error with an MMS note field. They're not displayed in the UI. Do you have any auto-created MMS fields present in your site?
Oct 15, 2013 at 6:13 PM

I'm a Site Collection Administrator having the exact same issue that MikeGargone was describing..
I am using a SP2010 dev environment and have deployed the "SPUserPoll.YYYY-MM-DD.wsp" downloaded from this site.

Also seeing "Invalid field name. {b77cdbcf-5dce-4937-85a7-9fc202705c91} /Lists/SPUserPoll answers" in SP Manager2010.
To my knowledge, I do not have any auto-created MMS (Managed Metadata Service) Fields present in my site. I've checked each column in each list at the Site Collection level to see if there are any Managed Metadata Types. (hopefully I am not misunderstanding what MMS stands for).

Either way, I am definitely running into the same issue where during the config of the webpart, I click "Manage Answers", and the page just seems to refresh.

Is there any update on this discussion?