Error: one or more fieldtypes not installed properly

Mar 6, 2009 at 11:14 AM
Hi,

We downloaded and installed your webpart in our environment but haven't been able to get it working.
We are on MOSS2007 with Dutch language pack.
I am able to add the webpart. I am also able to fill in the fields and click create poll. Sometimes this already causes an error (un unexpected error occured), sometimes it doesn't. But even when it does, I'm still able to navigate back to the page containing the webpart and manage answers.
The three lists are also created. But when I managed the answers and click publish poll I get an error: one or more fieldtypes are not installed properly. go to the list settings page and delete these fields (sorry, translated from dutch, maybe some translate errors here and there)
I am not able to navigate to the page with  the webpart in it anymore, all I get is the same error page over and over again. The only thing to fix this is to go to the manage content page of that page and delete the webpart.

I found on google that it could have something to do with the way the CAML query is build? http://www.sharepoint-tips.com/2007/04/one-of-more-field-types-are-not.html 
I can imagine the language module is the cause of this. Is there any way we can solve this? I am no programmer so I have no idea how to change the webpart. Can you help me?
It would be very much appreciated!
Coordinator
Mar 7, 2009 at 8:11 AM
Hi,

I'm Dutch, so if you post a few dutch error messages, that won't be a problem ;)

I will setup a clean moss2007 environment with a dutch languagepack to give it a test drive. Since 0.3 there is a fieldtype introduced to allow correct response editing. I guess the combination of this fieldtype and the languagepack gives a problem.

I give it a test as soon as possible and let you know the results. I hope I can reproduce it so it can be solved in a 0.3.1 release.

Regards,

Edwin
Mar 9, 2009 at 3:22 PM
Thx for your efforts :) If you need any more information, let me know. I will try to provide you with as much as I know.
Jun 25, 2009 at 7:14 PM

Hi,

 I also get the same problem. Error when click publish. I think it came from the answer list. Currently it only using one field (1st field) and I'm not sure how many field required. I like the way webpart is designed because easy to maintain. Unfortunately it's not working for me. Anybody has done it successfully. I'm using english version.

Sep 21, 2009 at 7:42 AM

Hello Edwin,

After installing the poll and adding it as a webpart to a dutch language pack enabled moss site I was able to create the poll answers, after publishing the webpart the following error oocured : (The message is in dutch :) )

"Een of meer veldtypen is niet goed geïnstalleerd. Ga naar de pagina met instellingen voor de lijst en verwijder deze velden."

The page inwhere the webpart lives, is not accessible anymore.  Hopefully you can help me out here.

 

Thanks in advance!